map module problem

map module problem was created by odd

Hi,

Chrome shows this on the post ads page:

Mixed Content: The page at '/'+\'\'+'*' was loaded over HTTPS, but requested an insecure script ' maps.googleapis.com/maps/api/js?sensor=false '. This request has been blocked; the content must be served over HTTPS.
VM2860:8 Uncaught ReferenceError: google is not defined(anonymous function) @ VM2860:8(anonymous function) @ post-classifieds:225


In addition, the map module does not show the location on the map, simply drops a pin somewhere in the Gulf of Guinea.

Needless to say, the site is in https

Any suggestions?
5 years 1 month ago#5906

Please Log in or Create an account to join the conversation.

Replied by Super User on topic map module problem

Dear Customer,

Kindly send your site URL, FTP details and Joomla admin access to This email address is being protected from spambots. You need JavaScript enabled to view it.. So that we will check and fix it.

Thanks.
5 years 1 month ago#5907

Please Log in or Create an account to join the conversation.

Replied by odd on topic map module problem

Sorry, can't do that - client's site. Can you point me to the correct file instead?
5 years 1 month ago#5916

Please Log in or Create an account to join the conversation.

Replied by Super User on topic map module problem

Hi,

Please send your site URL where you face this issue. So that we can check and update you.

Thanks.
5 years 1 month ago#5917

Please Log in or Create an account to join the conversation.

Replied by odd on topic map module problem

I wish I could, but I can't, for the same reason above.
The problem occurs with Chrome, IE detects a problem and asks whether I would like to load insecure content as well and when I confirm the map does load.
I already fixed two similar problems with youtube video links by editing

components/com_jomclassifieds/views/advert/tmpl/default.php
components/com_jomclassifieds/views/advert/tmpl/default_video.php
components/com_jomclassifieds/controller.php

by correcting http to https.

I am unable to locate the problematic http directive when it comes to the maps box, but I assume it's all this is about.

Would appreciate if you could point me there.
5 years 1 month ago#5919

Please Log in or Create an account to join the conversation.

Replied by Super User on topic map module problem

Hi,

Kindly open view.html.php file from the below path,

Root -> components -> com_jomclassifieds -> views -> user -> view.html.php

Find the below code in the above file :
http://maps.googleapis.com/maps/api/js?sensor=false

Replace it by the following code :
https://maps.googleapis.com/maps/api/js?sensor=false

Thanks.
The following user(s) said Thank You: odd
5 years 1 month ago#5920

Please Log in or Create an account to join the conversation.

Time to create page: 0.196 seconds

Contact us

  No.2/A, Venkateshwara Nagar,
1st Main Road, 100 Feet Road, SBM Towers, Velachery,Chennai - 600 042,India.
 admin@jomclassifieds.com
 skype.jomclassifieds
Copyright © 2013-2020 Jomclassifieds.com. All rights reserved. The Joomla! name, and logo are used under a limited license granted in the United States and other countries.