Welcome, Guest
Username: Password: Remember me

TOPIC: Security settings - Show captcha

Security settings - Show captcha 2 years 11 months ago #1538

Hi,
I am having issues with Captcha re-Captcha on my site.
I am runing your component which has the Show captcha configuration in its security settings.
The settings are set but my forms do not have the captcha graphic although the is a text
"Captcha * " where the graphic is supposed to be.

Any ideas why this is the case?
Thanks
Joe :(
mokanjo.com
jmatabe
The administrator has disabled public write access.

Security settings - Show captcha 2 years 11 months ago #1540

  • Super User
  • Super User's Avatar
  • Offline
  • Administrator
  • Posts: 2760
  • Thank you received: 292
  • Karma: 40
To fix this you need to change file /plugins/captcha/recaptcha/recaptcha.php

line 24
const RECAPTCHA_API_SERVER = "http://api.recaptcha.net";

to
const RECAPTCHA_API_SERVER = "http://api.recaptcha.net/recaptcha/api";

Google has change recaptcha code path and joomla hasn't still fixed this.

Thanks.
The administrator has disabled public write access.
Time to create page: 0.193 seconds