Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: map module problem

map module problem 1 year 1 month ago #5906

  • odd
  • odd 's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
Hi,

Chrome shows this on the post ads page:

Mixed Content: The page at 'https://*****' was loaded over HTTPS, but requested an insecure script 'maps.googleapis.com/maps/api/js?sensor=false'. This request has been blocked; the content must be served over HTTPS.
VM2860:8 Uncaught ReferenceError: google is not defined(anonymous function) @ VM2860:8(anonymous function) @ post-classifieds:225


In addition, the map module does not show the location on the map, simply drops a pin somewhere in the Gulf of Guinea.

Needless to say, the site is in https

Any suggestions?
The administrator has disabled public write access.

map module problem 1 year 1 month ago #5907

  • Super User
  • Super User's Avatar
  • Offline
  • Administrator
  • Posts: 2756
  • Thank you received: 291
  • Karma: 40
Dear Customer,

Kindly send your site URL, FTP details and Joomla admin access to This email address is being protected from spambots. You need JavaScript enabled to view it. . So that we will check and fix it.

Thanks.
The administrator has disabled public write access.

map module problem 1 year 1 month ago #5916

  • odd
  • odd 's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
Sorry, can't do that - client's site. Can you point me to the correct file instead?
The administrator has disabled public write access.

map module problem 1 year 1 month ago #5917

  • Super User
  • Super User's Avatar
  • Offline
  • Administrator
  • Posts: 2756
  • Thank you received: 291
  • Karma: 40
Hi,

Please send your site URL where you face this issue. So that we can check and update you.

Thanks.
The administrator has disabled public write access.

map module problem 1 year 1 month ago #5919

  • odd
  • odd 's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
I wish I could, but I can't, for the same reason above.
The problem occurs with Chrome, IE detects a problem and asks whether I would like to load insecure content as well and when I confirm the map does load.
I already fixed two similar problems with youtube video links by editing

components/com_jomclassifieds/views/advert/tmpl/default.php
components/com_jomclassifieds/views/advert/tmpl/default_video.php
components/com_jomclassifieds/controller.php

by correcting http to https.

I am unable to locate the problematic http directive when it comes to the maps box, but I assume it's all this is about.

Would appreciate if you could point me there.
The administrator has disabled public write access.

map module problem 1 year 1 month ago #5920

  • Super User
  • Super User's Avatar
  • Offline
  • Administrator
  • Posts: 2756
  • Thank you received: 291
  • Karma: 40
Hi,

Kindly open view.html.php file from the below path,

Root -> components -> com_jomclassifieds -> views -> user -> view.html.php

Find the below code in the above file :
http://maps.googleapis.com/maps/api/js?sensor=false

Replace it by the following code :
https://maps.googleapis.com/maps/api/js?sensor=false

Thanks.
The administrator has disabled public write access.
The following user(s) said Thank You: odd
  • Page:
  • 1
  • 2
Time to create page: 0.226 seconds