Welcome, Guest
Username: Password: Remember me

TOPIC: Cannot load images from phone

Cannot load images from phone 2 years 2 months ago #3790

  • BuyApet
  • BuyApet's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
hi.

After i try to submit a new ad with an image from any cell phone i get the following error.
Warning: preg_match(): Compilation failed: invalid range in character class at offset 7 in /home/buyapsih/public_html/administrator/components/com_jomclassifieds/etc/class.upload.php on line 2939
Warning: preg_match(): Compilation failed: invalid range in character class at offset 7 in /home/buyapsih/public_html/administrator/components/com_jomclassifieds/etc/class.upload.php on line 2993
Warning: preg_match(): Compilation failed: invalid range in character class at offset 7 in /home/buyapsih/public_html/administrator/components/com_jomclassifieds/etc/class.upload.php on line 3011

please assist

Regards
Lew
The administrator has disabled public write access.

Cannot load images from phone 2 years 2 months ago #3795

  • Super User
  • Super User's Avatar
  • Offline
  • Administrator
  • Posts: 2756
  • Thank you received: 291
  • Karma: 40
Dear Customer,

Kindly send the below details to This email address is being protected from spambots. You need JavaScript enabled to view it. .So that we will check and fix it.

1. Your site URL.
2. Joomla admin username and password.
3. Your site FTP details.

Thanks.
The administrator has disabled public write access.

Cannot load images from phone 2 years 2 months ago #3805

  • BuyApet
  • BuyApet's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
Hi. The error is not displayed any more. But the images still does not upload. It seems to be a image size related issue. You need to make the allowed size to be uploaded larger. Please fix this.
The administrator has disabled public write access.

Cannot load images from phone 2 years 2 months ago #3807

  • Super User
  • Super User's Avatar
  • Offline
  • Administrator
  • Posts: 2756
  • Thank you received: 291
  • Karma: 40
Dear Customer,

Apologies for the delay.

Actually your Hosting provider may restricted the upload size limit in your server. Check the below options to increase it.

Option 1

You can overwrite the php settings by using php.ini in your domain root directory. Open notepad and paste the below code and save the file as php.ini file.
safe_mode = off;
     file_uploads = on;
     session.cache_expire = 4000000000;
     upload_max_filesize = 1000M;
     post_max_size = 1010M;
     max_execution_time = 40000000;
     max_input_time = 40000000;
     memory_limit = 1010M;

If it does not work, you may try by placing the php.ini file in your directory which executes upload process.

Option 2

If your server administrator restricted the usage of php.ini then you may overwrite php settings using .htaccess file. Open notepad and paste the below code and save the file as ".htaccess" file and place it in the domain root directory.
php_flag safe_mode off
     php_value max_execution_time 1000
     php_value session.gc_maxlifetime 14000
     php_value output_buffering on
     php_value upload_max_filesize 104857600
     php_value post_max_size 104857600
     php_flag display_errors off

If both the above options does not work, then you may need to ask your server administrator for increasing file upload size.

Thanks.
The administrator has disabled public write access.
Time to create page: 0.299 seconds